View unanswered posts | View active topics It is currently Wed Dec 01, 2021 9:06 am



Reply to topic  [ 1 post ] 
 Linux install library linking problems 
Author Message

Joined: Fri Apr 20, 2012 9:09 pm
Posts: 3
Post Linux install library linking problems
Hello,

I'm currently having problems installing the glc_lib on linux.  What
seems to be happening is that I'm not linking the libaries correctly
so when I use qmake, then make I get errors saying all the Q functions
like QString, QFile, etc have not been defined.

I will let you know that I am a novice at programming and do not have
very much experience when it comes to using linux.  In fact, trying to
install this lib on a linux box was the first time I've used qmake and
make.



What I have been doing is editing the .pro file at this section, at the end
Code:
# Linux and macx install configuration
unix {
   # Location of HEADERS and library
   LIB_DIR = /usr/local/lib
   INCLUDE_DIR = /usr/local/include
   # Adds a -P to preserve link
   QMAKE_COPY_FILE = $${QMAKE_COPY_FILE} -P
   include.path = $${INCLUDE_DIR}/GLC_lib
   include_lib3ds.path = $${INCLUDE_DIR}/GLC_lib/3rdparty/lib3ds
   include_glext.path = $${INCLUDE_DIR}/GLC_lib/3rdparty/glext
   include_quazip.path = $${INCLUDE_DIR}/GLC_lib/3rdparty/quazip
   include_glc_maths.path = $${INCLUDE_DIR}/GLC_lib/maths
   include_glc_io.path = $${INCLUDE_DIR}/GLC_lib/io
   include_glc_scengraph.path = $${INCLUDE_DIR}/GLC_lib/sceneGraph
   include_glc_geometry.path = $${INCLUDE_DIR}/GLC_lib/geometry
   include_glc_shading.path = $${INCLUDE_DIR}/GLC_lib/shading
   include_glc_viewport.path = $${INCLUDE_DIR}/GLC_lib/viewport
   include_glc_3dwidget.path = $${INCLUDE_DIR}/GLC_lib/3DWidget
}


Where I replace
Code:
   LIB_DIR = /usr/local/lib
   INCLUDE_DIR = /usr/local/include


with
Code:
   LIB_DIR = /home/Alex/qtsdk-2010.02/qt/lib
   INCLUDE_DIR = /home/Alex/qtsdk-2010.02/qt/include


Is there something else I should change?  The glc_lib folder I'm
installing from I just left on the desktop.

As for my version, I am using QT Creator 1.3.1 Based on Qt 4.6.2 (32-bit)

I appreciate any help you can offer.


Tue Apr 24, 2012 8:06 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.